En resumen
- CVE-2017-18342 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a pyyaml, pyyaml (pyyaml).
- Probabilidad de explotación en los próximos 30 días (EPSS): 5.7%, mayor que el 93.0% de las vulnerabilidades.
- Solución: actualizar a 5.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| pyyaml PyPI | < 5.1
| 5.1
|
| pyyaml | < 5.1
| 5.1
|
Description
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code. In other words, yaml.safe_load is not used.
This was intended to be fixed in 4.1, but due to breaking changes, 4.1 was yanked and 5.1 contains the patch for CVE-2017-18342.
NVD description
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free