En resumen
- CVE-2018-1000118 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a electron (electronjs), electron.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.4%, mayor que el 84.1% de las vulnerabilidades.
- Solución: actualizar a 1.8.2-beta5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| electron | = 1.8.2≤ 1.8.1
| No fix yet |
| electron npm | < 1.8.2-beta5
| 1.8.2-beta5
|
Description
Github Electron version Electron 1.8.2-beta.4 and earlier contains a Command Injection vulnerability in Protocol Handler that can result in command execute. This attack appear to be exploitable via the victim opening an electron protocol handler in their browser. This vulnerability appears to have been fixed in Electron 1.8.2-beta.5. This issue is due to an incomplete fix for CVE-2018-1000006, specifically the black list used was not case insensitive allowing an attacker to potentially bypass it.
NVD description
Github Electron version Electron 1.8.2-beta.4 and earlier contains a Command Injection vulnerability in Protocol Handler that can result in command execute. This attack appear to be exploitable via the victim opening an electron protocol handler in their browser. This vulnerability appears to have been fixed in Electron 1.8.2-beta.5. This issue is due to an incomplete fix for CVE-2018-1000006, specifically the black list used was not case insensitive allowing an attacker to potentially bypass it.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free