En resumen
- CVE-2018-1000539 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a json-jwt, json-jwt (json-jwt project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.6% de las vulnerabilidades.
- Solución: actualizar a 1.9.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| json-jwt RubyGems | ≥ 0.5.1, < 1.9.4
| 1.9.4
|
| json-jwt | ≥ 0.5.0, < 1.9.4
| 1.9.4
|
Description
The json-jwt rubygem version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption of AES-GCM encrypted JSON Web Tokens that can result in Attacker can forge a authentication tag. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 1.9.4 and later.
NVD description
Nov json-jwt version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption of AES-GCM encrypted JSON Web Tokens that can result in Attacker can forge a authentication tag. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 1.9.4 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free