En resumen
- CVE-2018-1000613 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a org.bouncycastle:bcprov-jdk15on, bc-java (bouncycastle), api gateway (oracle).
- Probabilidad de explotación en los próximos 30 días (EPSS): 4.8%, mayor que el 91.9% de las vulnerabilidades.
- Solución: actualizar a 1.60, 7.0.0.1, 7.2 o posterior.
Description
Legion of the Bouncy Castle Java Cryptography APIs starting in version 1.57 and prior to version 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application.
This vulnerability appears to have been fixed in 1.60 and later.
NVD description
Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.
Más vulnerabilidades de org.bouncycastle:bcprov-jdk15on
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free