En resumen
- CVE-2018-1000656 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a flask, flask (palletsprojects).
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.9%, mayor que el 90.2% de las vulnerabilidades.
- Solución: actualizar a 0.12.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| flask PyPI | < 0.12.3
| 0.12.3
|
| flask | < 0.12.3
| 0.12.3
|
Description
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3.
NVD description
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free