En resumen
- CVE-2018-1002203 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a unzipper (unzipper project), unzipper.
- Probabilidad de explotación en los próximos 30 días (EPSS): 10.6%, mayor que el 95.8% de las vulnerabilidades.
- Solución: actualizar a 0.8.13 o posterior.
| Package | Affected versions | Patched versions |
|---|
| unzipper | < 0.8.13
| 0.8.13
|
| unzipper npm | < 0.8.13
| 0.8.13
|
Description
Versions of unzipper before 0.8.13 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.3.18 or later.
NVD description
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free