En resumen
- CVE-2018-14732 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a webpack-dev-server (webpack.js), webpack-dev-server.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.5%, mayor que el 84.6% de las vulnerabilidades.
- Solución: actualizar a 3.1.6, 3.1.11 o posterior.
Description
Versions of webpack-dev-server before 3.1.10 are missing origin validation on the websocket server. This vulnerability allows a remote attacker to steal a developer's source code because the origin of requests to the websocket server that is used for Hot Module Replacement (HMR) are not validated.
Recommendation
For webpack-dev-server update to version 3.1.11 or later.
NVD description
An issue was discovered in lib/Server.js in webpack-dev-server before 3.1.6. Attackers are able to steal developer's code because the origin of requests is not checked by the WebSocket server, which is used for HMR (Hot Module Replacement). Anyone can receive the HMR message sent by the WebSocket server via a ws://127.0.0.1:8080/ connection from any origin.
Más vulnerabilidades de webpack-dev-server
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free