En resumen
- CVE-2018-16469 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a merge (merge project), merge.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.0% de las vulnerabilidades.
- Solución: actualizar a 1.2.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| merge | < 1.2.1
| 1.2.1
|
| merge npm | < 1.2.1
| 1.2.1
|
Description
Versions of merge before 1.2.1 are vulnerable to prototype pollution. The merge.recursive function can be tricked into adding or modifying properties of the Object prototype.
Recommendation
Update to version 1.2.1 or later.
NVD description
The merge.recursive function in the merge package <1.2.1 can be tricked into adding or modifying properties of the Object prototype. These properties will be present on all objects allowing for a denial of service attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free