En resumen
- CVE-2018-16491 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a node.extend (dreamerslab), node.extend.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.6% de las vulnerabilidades.
- Solución: actualizar a 2.0.1, 1.1.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| node.extend | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
| node.extend npm | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
Description
Versions of node.extend before 1.1.7 or 2.0.1 are vulnerable to prototype pollution.
Recommendation
Update to version 1.1.7, 2.0.1 or later.
NVD description
A prototype pollution vulnerability was found in node.extend <1.1.7, ~<2.0.1 that allows an attacker to inject arbitrary properties onto Object.prototype.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free