En resumen
- CVE-2018-25031 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a org.webjars:swagger-ui, swagger ui (smartbear), swagger-ui.
- Probabilidad de explotación en los próximos 30 días (EPSS): 42.3%, mayor que el 98.7% de las vulnerabilidades.
- Solución: actualizar a 4.1.3 o posterior.
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
NVD description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Más vulnerabilidades de org.webjars:swagger-ui
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free