En resumen
- CVE-2018-3711 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a fastify (fastify), fastify.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.8%, mayor que el 78.1% de las vulnerabilidades.
- Solución: actualizar a 0.38.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| fastify | < 0.38.0
| 0.38.0
|
| fastify npm | < 0.38.0
| 0.38.0
|
Description
Affected versions of fastify are vulnerable to a denial of service when processing a request with Content-Type set to application/json and a very large payload.
Recommendation
Update to version 0.38.0 or later.
NVD description
Fastify node module before 0.38.0 is vulnerable to a denial-of-service attack by sending a request with "Content-Type: application/json" and a very large payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free