En resumen
- CVE-2018-3715 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a glance (glance project), glance.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.5%, mayor que el 73.6% de las vulnerabilidades.
- Solución: actualizar a 3.0.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free