En resumen
- CVE-2018-3720 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a assign-deep (assign-deep project), assign-deep.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.0%, mayor que el 80.7% de las vulnerabilidades.
- Solución: actualizar a 0.4.7 o posterior.
Description
Versions of assign-deep before 0.4.7 are vulnerable to prototype pollution via merging functions.
Recommendation
Update to version 0.4.7 or later.
NVD description
assign-deep node module before 0.4.7 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free