En resumen
- CVE-2018-3725 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a hekto (hekto project), hekto.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.0%, mayor que el 80.9% de las vulnerabilidades.
- Solución: actualizar a 0.2.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| hekto | = 0.2.0
| No fix yet |
| hekto npm | < 0.2.3
| 0.2.3
|
Description
Versions of hekto before 0.2.3 are vulnerable to path traversal. This allows a remote attacker to read content of arbitrary files.
Recommendation
Update to version 0.2.3 or later.
NVD description
hekto node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free