En resumen
- CVE-2018-3739 es una vulnerabilidad CRÍTICO (CVSS 9.1) que afecta a https-proxy-agent (https-proxy-agent project), https-proxy-agent.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.8% de las vulnerabilidades.
- Solución: actualizar a 2.2.0 o posterior.
Description
Versions of https-proxy-agent before 2.2.0 are vulnerable to denial of service. This is due to unsanitized options (proxy.auth) being passed to Buffer().
Recommendation
Update to version 2.2.0 or later.
NVD description
https-proxy-agent before 2.1.1 passes auth option to the Buffer constructor without proper sanitization, resulting in DoS and uninitialized memory leak in setups where an attacker could submit typed input to the 'auth' parameter (e.g. JSON).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free