En resumen
- CVE-2018-3750 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a deep extend (deep extend project), deep-extend.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.1%, mayor que el 82.2% de las vulnerabilidades.
- Solución: actualizar a 0.5.1 o posterior.
Description
Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution.
Recommendation
Update to version 0.5.1 or later.
NVD description
The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free