En resumen
- CVE-2018-3752 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a merge-options (merge-options project), merge-options.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.4%, mayor que el 73.2% de las vulnerabilidades.
- Solución: actualizar a 1.0.1 o posterior.
Description
All versions of merge-options are vulnerable to Prototype Pollution
Recommendation
Update to version 1.0.1 or greater.
NVD description
The utilities function in all versions <= 1.0.0 of the merge-options node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free