En resumen
- CVE-2018-3767 es una vulnerabilidad CRÍTICO (CVSS 9.1) que afecta a memjs (memcachier), memjs.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.5%, mayor que el 73.6% de las vulnerabilidades.
- Aún no hay una versión corregida: sigue el aviso del fabricante en Referencias.
| Package | Affected versions | Patched versions |
|---|
| memjs | ≤ 1.1.0
| No fix yet |
| memjs npm | ≤ 1.2.0
| No fix yet |
Description
Versions of memjs prior to 1.2.2 are vulnerable to Denial of Service (DoS). The package fails to sanitize the value option passed to the Buffer constructor, which may allow attackers to pass large values exhausting system resources.
Recommendation
Upgrade to version 1.2.2 or later.
NVD description
`memjs` versions <= 1.1.0 allocates and stores buffers on typed input, resulting in DoS and uninitialized memory usage.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free