En resumen
- CVE-2018-3774 es una vulnerabilidad CRÍTICO (CVSS 10.0) que afecta a url-parse.
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.8%, mayor que el 90.0% de las vulnerabilidades.
- Solución: actualizar a 1.4.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| url-parse npm | ≥ 1.0.0, < 1.4.3
| 1.4.3
|
Description
Versions of url-parse before 1.4.3 returns the wrong hostname which could lead to Open Redirect, Server Side Request Forgery (SSRF), or Bypass Authentication Protocol vulnerabilities.
Recommendation
Update to version 1.4.3 or later.
NVD description
Incorrect parsing in url-parse <1.4.3 returns wrong hostname which leads to multiple vulnerabilities such as SSRF, Open Redirect, Bypass Authentication Protocol.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free