En resumen
- CVE-2018-7651 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a ssri (ssri project), ssri.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.4% de las vulnerabilidades.
- Solución: actualizar a 5.2.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| ssri | < 5.2.2
| 5.2.2
|
| ssri npm | < 5.2.2
| 5.2.2
|
Description
Version of ssri prior to 5.2.2 are vulnerable to regular expression denial of service (ReDoS) when using strict mode.
Recommendation
Update to version 5.2.2 or later.
NVD description
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free