En resumen
- CVE-2018-8025 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a org.apache.hbase:hbase-thrift, hbase (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.7% de las vulnerabilidades.
- Solución: actualizar a 1.3.2.1, 1.4.5, 2.0.1, 1.2.6.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hbase:hbase-thrift Maven | ≥ 1.3.0, < 1.3.2.1≥ 1.4.0, < 1.4.5≥ 2.0.0, < 2.0.1< 1.2.6.1
| 1.3.2.11.4.52.0.11.2.6.1
|
| hbase | = 0.92.0> 1.0.0, ≤ 2.0.0
| No fix yet |
Description
An issue in Apache HBase affects the optional "Thrift 1" API server when running over HTTP. There is a race-condition which could lead to authenticated sessions being incorrectly applied to users, e.g. one authenticated user would be considered a different user or an unauthenticated user would be treated as an authenticated user. https://issues.apache.org/jira/browse/HBASE-20664 implements a fix for this issue. It has been fixed in versions: 1.2.6.1, 1.3.2.1, 1.4.5, 2.0.1.
NVD description
CVE-2018-8025 describes an issue in Apache HBase that affects the optional "Thrift 1" API server when running over HTTP. There is a race-condition which could lead to authenticated sessions being incorrectly applied to users, e.g. one authenticated user would be considered a different user or an unauthenticated user would be treated as an authenticated user. https://issues.apache.org/jira/browse/HBASE-20664 implements a fix for this issue. It has been fixed in versions: 1.2.6.1, 1.3.2.1, 1.4.5, 2.0.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free