En resumen
- CVE-2019-0187 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a org.apache.jmeter:ApacheJMeter, jmeter (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.6%, mayor que el 85.6% de las vulnerabilidades.
- Solución: actualizar a 5.1 o posterior.
Description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
NVD description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
Más vulnerabilidades de org.apache.jmeter:ApacheJMeter
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free