En resumen
- CVE-2019-1000011 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a api-platform/core, core (api-platform).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.0%, mayor que el 63.7% de las vulnerabilidades.
- Solución: actualizar a 2.2.10, 2.3.6 o posterior.
| Package | Affected versions | Patched versions |
|---|
| api-platform/core Packagist | ≥ 2.2.0, < 2.2.10≥ 2.3.0, < 2.3.6
| 2.2.102.3.6
|
| core | ≥ 2.2.0, ≤ 2.3.5
| No fix yet |
Description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
NVD description
API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control vulnerability in GraphQL delete mutations that can result in a user authorized to delete a resource can delete any resource. This attack appears to be exploitable via the user must be authorized. This vulnerability appears to have been fixed in 2.3.6.
Más vulnerabilidades de api-platform/core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free