En resumen
- CVE-2019-1010275 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a helm.sh/helm, helm (helm).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.4%, mayor que el 71.7% de las vulnerabilidades.
- Solución: actualizar a 2.7.2, 2.7.2+incompatible o posterior.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | < 2.7.2< 2.7.2+incompatible
| 2.7.22.7.2+incompatible
|
| helm | < 2.7.2
| 2.7.2
|
Description
helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.
NVD description
helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free