En resumen
- CVE-2019-13173 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a fstream (fstream project), fstream.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.4%, mayor que el 84.3% de las vulnerabilidades.
- Solución: actualizar a 1.0.12 o posterior.
| Package | Affected versions | Patched versions |
|---|
| fstream | < 1.0.12
| 1.0.12
|
| fstream npm | < 1.0.12
| 1.0.12
|
Description
Versions of fstream prior to 1.0.12 are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system and a file that matches the hardlink will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Recommendation
Upgrade to version 1.0.12 or later.
NVD description
fstream before 1.0.12 is vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink, will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free