En resumen
- CVE-2019-15608 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a yarn (yarnpkg), yarn.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.8%, mayor que el 79.0% de las vulnerabilidades.
- Solución: actualizar a 1.19.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| yarn | < 1.19.0
| 1.19.0
|
| yarn npm | < 1.19.0
| 1.19.0
|
Description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.
NVD description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free