En resumen
- CVE-2019-16766 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a wagtail-2fa, wagtail-2fa (labdigital).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.5%, mayor que el 73.8% de las vulnerabilidades.
- Solución: actualizar a 1.3.0 o posterior.
Description
2FA bypass through new device path
Impact
If someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS.
Patches
This problem has been patched in version 1.3.0.
Workarounds
There is no workaround at the moment.
For more information
If you have any questions or comments about this advisory:
NVD description
When using wagtail-2fa before 1.3.0, if someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS. This problem has been patched in version 1.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free