En resumen
- CVE-2019-19609 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a strapi (strapi), strapi.
- Probabilidad de explotación en los próximos 30 días (EPSS): 54.1%, mayor que el 99.0% de las vulnerabilidades.
- Solución: actualizar a 3.0.0-beta.17.8 o posterior.
| Package | Affected versions | Patched versions |
|---|
| strapi | = 3.0.0≤ 1.6.4
| No fix yet |
| strapi npm | < 3.0.0-beta.17.8
| 3.0.0-beta.17.8
|
Description
Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.
Recommendation
Upgrade to version 3.0.0-beta.17.8 or later
NVD description
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free