En resumen
- CVE-2020-11054 es una vulnerabilidad BAJO (CVSS 3.5) que afecta a qutebrowser, qutebrowser (qutebrowser).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.5%, mayor que el 74.5% de las vulnerabilidades.
- Solución: actualizar a 1.11.0, 1.11.1 o posterior.
Description
Description
After a certificate error was overridden by the user, qutebrowser displays the URL as yellow (colors.statusbar.url.warn.fg). However, when the affected website was subsequently loaded again, the URL was mistakenly displayed as green (colors.statusbar.url.success_https). While the user already has seen a certificate error prompt at this point (or set content.ssl_strict to false which is not recommended), this could still provide a false sense of security.
Affected versions and patches
All versions of qutebrowser are believed to be affected, though versions before v0.11.x couldn't be tested.
The issue is fixed in qutebrowser v1.11.1 (pending release) and v1.12.0 (unreleased). Backported patches for older versions are available, but no further releases are planned.
Mitigation
If you are unable to upgrade:
- Treat any host with a certificate exception as insecure, ignoring the URL color
- Or set
content.ssl_strict to True (instead of 'ask'), preventing certificate exceptions
References
NVD description
In qutebrowser versions less than 1.11.1, reloading a page with certificate errors shows a green URL. After a certificate error was overridden by the user, qutebrowser displays the URL as yellow (colors.statusbar.url.warn.fg). However, when the affected website was subsequently loaded again, the URL was mistakenly displayed as green (colors.statusbar.url.success_https). While the user already has seen a certificate error prompt at this point (or set content.ssl_strict to false, which is not recommended), this could still provide a false sense of security. This has been fixed in 1.11.1 and 1.12.0. All versions of qutebrowser are believed to be affected, though versions before v0.11.x couldn't be tested. Backported patches for older versions (greater than or equal to 1.4.0 and less than or equal to 1.10.2) are available, but no further releases are planned.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free