En resumen
- CVE-2020-15242 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a next.js (vercel), next.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.7% de las vulnerabilidades.
- Solución: actualizar a 9.5.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
| next npm | ≥ 9.5.0, < 9.5.4
| 9.5.4
|
Description
NVD description
Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free