En resumen
- CVE-2020-26296 es una vulnerabilidad ALTO (CVSS 8.7) que afecta a vega (vega project), vega.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.4% de las vulnerabilidades.
- Solución: actualizar a 5.17.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| vega | < 5.17.3
| 5.17.3
|
| vega npm | < 5.17.3
| 5.17.3
|
Description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package.
In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could
execute arbitrary javascript on a victim's machine.
This is fixed in version 5.17.3
NVD description
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free