En resumen
- CVE-2020-4066 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a limdu (limdu project), limdu.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.6%, mayor que el 76.3% de las vulnerabilidades.
- Solución: actualizar a 0.9.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| limdu | < 0.9.5
| 0.9.5
|
| limdu npm | < 0.9.5
| 0.9.5
|
Description
Impact
The trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability.
Patches
Patched in version 0.9.5.
Workarounds
Do not use trainBatch with classifiers that rely on shell execution, such as SVM Perf, SVM Linear or Adaboost
References
No
NVD description
In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free