En resumen
- CVE-2021-29454 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a smarty/smarty, smarty (smarty).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.8%, mayor que el 78.5% de las vulnerabilidades.
- Solución: actualizar a 4.0.2, 3.1.42 o posterior.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
| smarty | ≥ 4.0.0, < 4.0.2< 3.1.42
| 4.0.23.1.42
|
Description
Impact
Template authors could run arbitrary PHP code by crafting a malicious math string.
If a math string is passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string.
Patches
Please upgrade to 4.0.2 or 3.1.42 or higher.
References
See documentation on Math function.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free