En resumen
- CVE-2021-32740 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a addressable, addressable (addressable project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.1%, mayor que el 82.1% de las vulnerabilidades.
- Solución: actualizar a 2.8.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| addressable RubyGems | ≥ 2.3.0, < 2.8.0
| 2.8.0
|
| addressable | ≥ 2.3.0, < 2.8.0
| 2.8.0
|
Description
Impact
Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected.
Patches
The vulnerability was introduced in version 2.3.0 (previously yanked) and has been present in all subsequent versions up to, and including, 2.7.0. It is fixed in version 2.8.0.
Workarounds
The vulnerability can be avoided by only creating Template objects from trusted sources that have been validated not to produce catastrophic backtracking.
References
For more information
If you have any questions or comments about this advisory:
NVD description
Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. An uncontrolled resource consumption vulnerability exists after version 2.3.0 through version 2.7.0. Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected. The vulnerability is patched in version 2.8.0. As a workaround, only create Template objects from trusted sources that have been validated not to produce catastrophic backtracking.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free