| Package | Affected versions | Patched versions |
|---|---|---|
| circles | ≥ 0.20.0, < 0.20.10≥ 0.21.0, < 0.21.3< 0.19.14 | 0.20.100.21.30.19.14 |
Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free