En resumen
- CVE-2021-32805 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a flask-appbuilder, flask-appbuilder (dpgaspar).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.70%, mayor que el 53.2% de las vulnerabilidades.
- Solución: actualizar a 3.3.2 o posterior.
Description
Impact
If using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability
Patches
Install Flask-AppBuilder 3.2.2 or above
Workarounds
Filter HTTP traffic containing ?next={next-site} where the next-site domain is different from the application you are protecting
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. In affected versions if using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability. To resolve this issue upgrade to Flask-AppBuilder 3.2.2 or above. If upgrading is infeasible users may filter HTTP traffic containing `?next={next-site}` where the `next-site` domain is different from the application you are protecting as a workaround.
Más vulnerabilidades de flask-appbuilder
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free