En resumen
- CVE-2021-36162 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a org.apache.dubbo:dubbo, dubbo (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.3%, mayor que el 83.0% de las vulnerabilidades.
- Solución: actualizar a 3.0.2, 2.7.13 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.dubbo:dubbo Maven | ≥ 3.0.0, < 3.0.2< 2.7.13
| 3.0.22.7.13
|
| dubbo | ≥ 2.7.0, ≤ 2.7.12≥ 3.0.0, ≤ 3.0.1
| No fix yet |
Description
Apache Dubbo supports various rules to support configuration override or traffic routing (called routing in Dubbo). These rules are loaded into the configuration center (eg: Zookeeper, Nacos, ...) and retrieved by the customers when making a request in order to find the right endpoint. When parsing these YAML rules, Dubbo customers will use SnakeYAML library to load the rules which by default will enable calling arbitrary constructors. An attacker with access to the configuration center he will be able to poison the rule so when retrieved by the consumers, it will get RCE on all of them. This was fixed in Dubbo 2.7.13, 3.0.2
NVD description
Apache Dubbo supports various rules to support configuration override or traffic routing (called routing in Dubbo). These rules are loaded into the configuration center (eg: Zookeeper, Nacos, ...) and retrieved by the customers when making a request in order to find the right endpoint. When parsing these YAML rules, Dubbo customers will use SnakeYAML library to load the rules which by default will enable calling arbitrary constructors. An attacker with access to the configuration center he will be able to poison the rule so when retrieved by the consumers, it will get RCE on all of them. This was fixed in Dubbo 2.7.13, 3.0.2
Más vulnerabilidades de org.apache.dubbo:dubbo
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free