En resumen
- CVE-2021-37404 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a org.apache.hadoop:hadoop-common, hadoop (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.0%, mayor que el 87.3% de las vulnerabilidades.
- Solución: actualizar a 3.2.3, 3.3.2, 2.10.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-common Maven | ≥ 3.0.0, < 3.2.3≥ 3.3.0, < 3.3.2< 2.10.2
| 3.2.33.3.22.10.2
|
| hadoop | ≥ 2.9.0, < 2.10.2≥ 3.0.0, ≤ 3.1.4≥ 3.2.0, < 3.2.3≥ 3.3.0, < 3.3.2
| 2.10.23.2.33.3.2
|
Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
NVD description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Más vulnerabilidades de org.apache.hadoop:hadoop-common
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free