En resumen
- CVE-2021-39171 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a passport-saml (passport-saml project), passport-saml.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.3%, mayor que el 71.1% de las vulnerabilidades.
- Solución: actualizar a 3.1.0 o posterior.
Description
Impact
A malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack.
Patches
This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
References
https://github.com/node-saml/passport-saml/pull/595
NVD description
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free