En resumen
- CVE-2021-40110 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a org.apache.james:james-server, james (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.0%, mayor que el 87.2% de las vulnerabilidades.
- Solución: actualizar a 3.6.1 o posterior.
Description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
NVD description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
Más vulnerabilidades de org.apache.james:james-server
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free