En resumen
- CVE-2021-40111 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a org.apache.james:james-server, james (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.5% de las vulnerabilidades.
- Solución: actualizar a 3.6.1 o posterior.
Description
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
NVD description
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
Más vulnerabilidades de org.apache.james:james-server
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free