En resumen
- CVE-2021-41122 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a vyper, vyper (vyperlang).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.80%, mayor que el 56.7% de las vulnerabilidades.
- Solución: actualizar a 0.3.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | < 0.3.0
| 0.3.0
|
| vyper | < 0.3.0
| 0.3.0
|
Description
Impact
The following code does not properly validate that its input is in bounds.
@external
def foo(x: decimal) -> decimal:
return x
Patches
0.3.0 / #2447
Workarounds
Don't use decimal args
NVD description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free