En resumen
- CVE-2022-21647 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a codeigniter4/framework, codeigniter (codeigniter).
- Probabilidad de explotación en los próximos 30 días (EPSS): 37.7%, mayor que el 98.5% de las vulnerabilidades.
- Solución: actualizar a 4.1.6 o posterior.
Description
Impact
Deserialization of Untrusted Data was found in the old() function in CodeIgniter4.
Remote attackers may inject auto-loadable arbitrary objects with this vulnerability,
and possibly execute existing PHP code on the server.
We are aware of a working exploit, which can lead to SQL injection.
Patches
Upgrade to v4.1.6 or later.
Workarounds
Do not use:
old() and form_helper
RedirectResponse::withInput() and redirect()->withInput()
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
Más vulnerabilidades de codeigniter4/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free