En resumen
- CVE-2022-21648 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a latte/latte, latte (nette).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.84%, mayor que el 58.0% de las vulnerabilidades.
- Solución: actualizar a 2.10.8, 2.8.8, 2.9.6 o posterior.
| Package | Affected versions | Patched versions |
|---|
| latte/latte Packagist | ≥ 2.10.0, < 2.10.8≥ 2.8.0, < 2.8.8≥ 2.9.0, < 2.9.6
| 2.10.82.8.82.9.6
|
| latte | ≥ 2.10.0, < 2.10.8≥ 2.8.0, < 2.8.8≥ 2.9.0, < 2.9.6
| 2.10.82.8.82.9.6
|
Description
Impact
The problem affects users who use the sandbox in Latte and templates from untrusted sources.
Patches
Sandbox first appeared in Latte 2.8.0. The issue is fixed in the versions 2.8.8, 2.9.6 and 2.10.8.
References
The issues were discovered by
NVD description
Latte is an open source template engine for PHP. Versions since 2.8.0 Latte has included a template sandbox and in affected versions it has been found that a sandbox escape exists allowing for injection into web pages generated from Latte. This may lead to XSS attacks. The issue is fixed in the versions 2.8.8, 2.9.6 and 2.10.8. Users unable to upgrade should not accept template input from untrusted sources.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free