En resumen
- CVE-2022-23505 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a passport-wsfed-saml2 (auth0), passport-wsfed-saml2.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.80%, mayor que el 56.6% de las vulnerabilidades.
- Solución: actualizar a 4.6.3 o posterior.
Description
Overview
A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered.
Am I affected?
You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3.
SAML2 protocol is not affected.
How do I fix it?
Upgrade the library to version 4.6.3.
Will the fix impact my users?
No, the fix will not impact your users.
NVD description
Passport-wsfed-saml2 is a ws-federation protocol and SAML2 tokens authentication provider for Passport. In versions prior to 4.6.3, a remote attacker may be able to bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. This issue is patched in version 4.6.3. Use of SAML2 authentication instead of WSFed is a workaround.
Más vulnerabilidades de passport-wsfed-saml2
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free