| Package | Affected versions | Patched versions |
|---|---|---|
| rails-html-sanitizer | < 1.4.4 | 1.4.4 |
| rails html sanitizers | < 1.4.4 | 1.4.4 |
Certain configurations of rails-html-sanitizer < 1.4.4 use an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption.
Upgrade to rails-html-sanitizer >= 1.4.4.
The maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
This vulnerability was responsibly reported by @ooooooo-q (https://github.com/ooooooo-q).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free