En resumen
- CVE-2022-23556 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a codeigniter4/framework, codeigniter (codeigniter).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.40%, mayor que el 34.0% de las vulnerabilidades.
- Solución: actualizar a 4.2.11 o posterior.
Description
Impact
This vulnerability may allow attackers to spoof their IP address when your server is behind a reverse proxy.
Patches
Upgrade to v4.2.11 or later, and configure Config\App::$proxyIPs.
Workarounds
Do not use $request->getIPAddress().
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.
Más vulnerabilidades de codeigniter4/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free