En resumen
- CVE-2022-24686 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a github.com/hashicorp/nomad, nomad (hashicorp).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.86%, mayor que el 58.5% de las vulnerabilidades.
- Solución: actualizar a 1.0.18, 1.1.12, 1.2.6 o posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | ≥ 0.3.0, < 1.0.18≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.0.181.1.121.2.6
|
| nomad | ≥ 0.3.0, < 1.0.18≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.0.181.1.121.2.6
|
Description
HashiCorp Nomad and Nomad Enterprise 0.3.0 through 1.0.17, 1.1.11, and 1.2.5 artifact download functionality has a race condition such that the Nomad client agent could download the wrong artifact into the wrong destination. This issue is fixed in 1.0.18, 1.1.12, and 1.2.6.
NVD description
HashiCorp Nomad and Nomad Enterprise 0.3.0 through 1.0.17, 1.1.11, and 1.2.5 artifact download functionality has a race condition such that the Nomad client agent could download the wrong artifact into the wrong destination. Fixed in 1.0.18, 1.1.12, and 1.2.6
Más vulnerabilidades de github.com/hashicorp/nomad
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free