En resumen
- CVE-2022-24711 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a codeigniter4/framework, codeigniter (codeigniter).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.2%, mayor que el 67.5% de las vulnerabilidades.
- Solución: actualizar a 4.1.9 o posterior.
Description
Impact
This vulnerability allows attackers to execute CLI routes via HTTP request.
Patches
Upgrade to v4.1.9 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.
Más vulnerabilidades de codeigniter4/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free