En resumen
- CVE-2022-24759 es una vulnerabilidad ALTO (CVSS 7.4) que afecta a js-libp2p-noise (chainsafe), @chainsafe/libp2p-noise.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.50%, mayor que el 42.9% de las vulnerabilidades.
- Solución: actualizar a 5.0.3, 4.1.2 o posterior.
Description
Impact
@chainsafe/libp2p-noise before 4.1.2 and 5.0.3 was not correctly validating signatures during the handshake process.
This may allow a man-in-the-middle to pose as other peers and get those peers banned.
Patches
Users should upgrade to 4.1.2 or 5.0.3
Workarounds
No workarounds, just patch upgrade
References
https://github.com/ChainSafe/js-libp2p-noise/pull/130
NVD description
`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free